[rabbitmq-discuss] SSL connection - ASN1 error

Skorepa, Michal Michal.Skorepa at Honeywell.com
Tue Oct 1 13:06:06 BST 2013

Thank you, Simon. But unfortunately neither of the proposed workarounds worked for me. Both produced the same error:


Do you have any other suggestions?

Also, when do you plan to release a new version of AMQP Erlang client?


-----Original Message-----
From: Simon MacMullen [mailto:simon at rabbitmq.com] 
Sent: 1. října 2013 11:43
To: Discussions about RabbitMQ
Cc: Skorepa, Michal
Subject: Re: [rabbitmq-discuss] SSL connection - ASN1 error

Hmm, I don't think we fixed that for the AMQP client. That'll get fixed in the next release.

As a workaround you can configure an SSL listener for the RabbitMQ server that's hosting this plugin, or (if you control the source code to the plugin) invoking application:start(asn1) before opening an SSL client connection.

Cheers, Simon

On 01/10/13 10:22, Skorepa, Michal wrote:
> Hello,
> I am getting an exception in SSL connection establishment by AMQP 
> Erlang client (used by an application which is running as a RMQ plugin):
> {error,{cannot_start_application,public_key,{not_started,asn1}}}
> I am running RabbitMQ 3.1.5 and Erlang R16B01. I know there have been 
> some issues in older versions of Rabbit, but it should have been fixed 
> since 3.1.2, I suppose.
> Can anybody clarify what the problem is?
> Thank you,
> Michal
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

Simon MacMullen
RabbitMQ, Pivotal

More information about the rabbitmq-discuss mailing list