[rabbitmq-discuss] SSL connection - ASN1 error

Tim Watson tim at rabbitmq.com
Wed Oct 16 12:37:48 BST 2013

Hi Michal,

On 1 Oct 2013, at 13:06, Skorepa, Michal wrote:
> Thank you, Simon. But unfortunately neither of the proposed workarounds worked for me. Both produced the same error:
> {{{{badmatch,error},[{tls_connection,dh_master_secret,5,[{file,"tls_connection.erl"},{line,2093}]},{tls_connection,certify,2,[{file,"tls_connection.erl"},{line,544}]},{tls_connection,next_state,4,[{file,"tls_connection.erl"},{line,2537}]},{gen_fsm,handle_msg,7,[{file,"gen_fsm.erl"},{line,505}]},{proc_lib,init_p_do_apply,3,[{file,"proc_lib.erl"},{line,239}]}]},{gen_fsm,sync_send_all_state_event,[<0.324.0>,{start,infinity},infinity]}},{gen_server,call,[<0.292.0>,connect,infinity]}}

That looks like a very different error from the one you'd see due to the asn1 application not being started.

> Do you have any other suggestions?
>> I am getting an exception in SSL connection establishment by AMQP 
>> Erlang client (used by an application which is running as a RMQ plugin):

Can you explain a bit more about what you're doing here? The stack trace above indicates a failure during cryptographic key generation, which seems odd under the circumstances. Is there any more information available in the logs? In particular, it would be useful to have some more context for the error, e.g., an INFO report from the process in which this crash occured.

> Also, when do you plan to release a new version of AMQP Erlang client?

AFAIK a new release should be imminent. Although we cannot make any guarantees about release timescales, I'd expect to see one either this week or early next.


More information about the rabbitmq-discuss mailing list