[rabbitmq-discuss] Unable to start Rabbit Server or Service

Emile Joubert emile at rabbitmq.com
Wed Feb 9 15:08:29 GMT 2011


Your Erlang installation appears to suffer some problem relating to 
spawning OS processes. This is probably quite independent of RabbitMQ.

Are executables allowed to launch from within
D:/ProgramData/DRS/DRS Web/ by the user running Erlang?
Is that directory a local disk with sufficient permissions, not a 
mounted network share?

Were you able to launch wish84s independently?

The multiple network cards shouldn't cause any problems. RabbitMQ 
listens on the default interface (:: or by default.



On 09/02/11 14:43, Paul Winters wrote:
> Emile,
> Thanks so much, here are the answers to your questions.
> Are you running the broker as an application or a service? Broker for
> now.  Service later.  Neither work.
> What is the console output?  I modified the batch file to output some
> variables.  I tried to set the NODE_IP_ADDRESS and received the same error.
> Activating RabbitMQ plugins ...
> 0 plugins activated:
> ______________________________________
> erl started
> ______________________________________
> **********************************
> ERLANG_HOME=D:\Program Files\DRS\DRS Web\erl5.7.4
> Web/RabbitDB/db/rabbit at UXXXXXXZ-mnesia\plugins-scratch\rabbit
> RABBITMQ_LOG_BASE=D:/ProgramData/DRS/DRS Web/RabbitDB/log
> Web/RabbitDB/db/rabbit at UXXXXXXZ-mnesia
> **********************************
> {"Kernel pid
> terminated",application_controller,"{application_start_failure,os_mon,{shutdown,{os_mon,start,[normal,[]]}}}"}
> Does %APPDATA%\RabbitMQ not contain anything at all? It contains the DB
> and logs directory and some files.
> In the "...mnesia\plugins-scratch\" folder there is a rabbit.boot,
> rabbit.rel, rabbit.script.  In the logs directory there are logs, but
> they are empty.
> Do you get the same error when you use the new windows installer? Yes.
> The installation process works on XP, Vista and Windows 2003.  The only
> difference I have found on this box is the multiple network cards.
> Thanks in advance,
> Paul
> On Wed, Feb 9, 2011 at 6:51 AM, Emile Joubert <emile at rabbitmq.com
> <mailto:emile at rabbitmq.com>> wrote:
>     On 09/02/11 11:22, Paul Winters wrote:
>         Greetings.  We are currently trying to run Rabbit on an
>         enterprise level
>         server that has multiple network cards/ip addresses.  When I run the
>         rabbitmq-server.bat file, the first call to erl.exe works, the
>         second
>         call fails with the attached crash dump.  A theory is that Rabbit is
>         grabbing the wrong IP, but we are unsure.
>         Also when trying to run erlang installation verification I get the
>         following error:
>         Error in process <0.36.0> with exit value: {{case_clause,
>         {1,{'EXIT',
>         {enoent, [{erlang, open_port,[{spawn,"d:/Program Files/ DRS/DRS
>         Web/erl5.7.4/lib/gs-1.5.11/priv/tcl/bin/wish84s.exe d:\Program
>         Files\DRS\DRS Web\erl5.7.4\lib\gs-1.5.11\priv\gstk.tcl...
>         I think the issues might be related.
>     toolbar:start() works fine for me on R13B03 on Windows even if the
>     Erlang installation path contains spaces. You should check that you
>     are able to launch wish84s independently.
>     Are you running the broker as an application or a service? What is
>     the console output? Does %APPDATA%\RabbitMQ not contain anything at
>     all? Do you get the same error when you use the new windows
>     installer? (See
>     http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/2011-February/011128.html
>     )

More information about the rabbitmq-discuss mailing list