[rabbitmq-discuss] Unable to start Rabbit Server or Service

Emile Joubert emile at rabbitmq.com
Wed Feb 9 12:51:43 GMT 2011

On 09/02/11 11:22, Paul Winters wrote:
> Greetings.  We are currently trying to run Rabbit on an enterprise level
> server that has multiple network cards/ip addresses.  When I run the
> rabbitmq-server.bat file, the first call to erl.exe works, the second
> call fails with the attached crash dump.  A theory is that Rabbit is
> grabbing the wrong IP, but we are unsure.
> Also when trying to run erlang installation verification I get the
> following error:
> Error in process <0.36.0> with exit value: {{case_clause, {1,{'EXIT',
> {enoent, [{erlang, open_port,[{spawn,"d:/Program Files/ DRS/DRS
> Web/erl5.7.4/lib/gs-1.5.11/priv/tcl/bin/wish84s.exe d:\Program
> Files\DRS\DRS Web\erl5.7.4\lib\gs-1.5.11\priv\gstk.tcl...
> I think the issues might be related.

toolbar:start() works fine for me on R13B03 on Windows even if the 
Erlang installation path contains spaces. You should check that you are 
able to launch wish84s independently.

Are you running the broker as an application or a service? What is the 
console output? Does %APPDATA%\RabbitMQ not contain anything at all? Do 
you get the same error when you use the new windows installer? (See



More information about the rabbitmq-discuss mailing list