[rabbitmq-discuss] error message trying to start stomp adapter?

Erik Anderson erikba at odysseus.anderson.name
Thu Jan 28 17:24:58 GMT 2010

On Jan 28, 4:22 am, Matthew Sackman <matt... at lshift.net> wrote:
> Hi Erik,
> On Wed, Jan 27, 2010 at 02:33:40PM -0800, Erik Anderson wrote:
> > I'm trying to write up instructions on how I got all this rabbitmq /
> > orbited / stomp running while installing this on our production server
> > and this time things don't seem to be working properly.  The
> > configuration files have changed a bit from the last time I've noticed
> > (upgraded from 1.7.0 to 1.7.1 on windows?)  This is the error message
> > that I'm getting, any obvious translation to the config entry I'm
> > doing wrong?
> > starting STOMP Adapter (binding to [{"",61613}])  ...{"Kernel
> > pid
> > terminated",application_controller,"{application_start_failure,rabbit_stomp ,
> > {{invalid_host,[49,50,55,46,48,46,48,46,49],timeout},
> > {rabbit_stomp,start,[normal,[]]}}}"}
> Hmm, that's a bit odd. I've just installed the stomp adaptor and
> literally with zero config, it all just works. This is building
> rabbitmq_v1_7_1 from source.
> The only things I have in my plugins dir are links to
> rabbitmq-erlang-client and rabbitmq-stomp.

For what it's worth, it looks on the surface in {invalid_host,
[49,50,55,46,48,46,48,46,49],timeout} that the numbers are the ascii
representation of "".  Along with a new delay that feels like
a timeout when launching the normal TCP listeners, was some of the
"short node" stuff done in the last version affecting this?

> > I'm getting this no matter what stomp_listeners entry I put in (or
> > even with no config at all) I still get this same error.
> > I have noticed that the "TCP Listeners" line takes longer to startup
> > with this version of RabbitMQ than the previous version did, even
> > before I ran rabbitmq-activate-plugins.bat, is that affecting this at
> > all?
> > These are the build commands that I used to get this built (on the
> > linux box in my office, once I downloaded all the dependent packages):
> > cd ~/rabbit/v1.7.1
> > ln -s rabbitmq-codegen-c73ecfc91be3 rabbitmq-codegen
> > ln -s rabbitmq-erlang-client-825eceaca84c rabbitmq-erlang-client
> > ln -s rabbitmq-public-umbrella-d1a272b28e90 rabbitmq-public-umbrella
> > ln -s rabbitmq-server-90e101fd8b67 rabbitmq-server
> > ln -s rabbitmq-stomp-da7859ff22c6 rabbitmq-stomp
> > ln -s rabbitmq-public-umbrella/include.mk
> > ln -s rabbitmq-erlang-client/dist/rabbit_common
> > ln -s rabbitmq-stomp/dist/rabbit_stomp.ez ../rabbit_stomp-1.7.1.ez
> > make -C rabbitmq-server
> > make -C rabbitmq-erlang-client
> > make -C rabbitmq-stomp
> Hmm, this is a bit odd. What we tend to recommend is that you have
> everything in rabbitmq-public-umbrella, so it'd look a bit like this:
> cd ~/rabbit/v1.7.1
> hg clonehttp://hg.rabbitmq.com/rabbitmq-public-umbrella
> cd rabbitmq-public-umbrella
> hg clonehttp://hg.rabbitmq.com/rabbitmq-codegen
> hg clonehttp://hg.rabbitmq.com/rabbitmq-server
> cd rabbitmq-server
> hg up -C rabbitmq_v1_7_1
> make -j
> cd -
> hg clonehttp://hg.rabbitmq.com/rabbitmq-erlang-client
> cd rabbitmq-erlang-client
> make
> cd -
> hg clonehttp://hg.rabbitmq.com/rabbitmq-stomp
> cd rabbitmq-stomp
> make
> cd -
> cd rabbitmq-server
> mkdir -p plugins
> cd !!$
> ln -s ../../rabbitmq-stomp
> ln -s ../../rabbitmq-erlang-client
> cd ..
> ./scripts/rabbitmq-activate-plugins
> make cleandb run
> Certainly, I've just run all of that lot, and it works fine for me!
> "tip" is one of the daftest "features" (and there are many) of hg. You
> should be at the head of default - that's certainly what I'm using.

Umm, I haven't gotten around to installing hg, I'm hoping that I don't
have to get involved enough in the development side of this, so I've
just been downloading packages from the website.  The "tip" thing is
because for two of the packages the files I download from the website
are named that (the others are long hash identities).  I'm also
compiling on a different machine from the server (which has absolutely
no hope of running that Makefile) and copying the .ez file into a
plugins folder I create myself under the rabbitmq_server folder.

> With regards configuration, we would suggest that you use the config file
> in /etc/rabbitmq/rabbitmq.config (though this can sometimes be in other
> places if eg you're using macports). Having a file like:
> [{rabbit_stomp, [{listeners, [{"",61612}]}]}].
> is by far the easiest way to configure plugins like this as it avoids
> nasty escaping issues if passing by env vars.

I haven't quite found the location of this file yet, and would like to
(if possible) move it to a more usable location (once I find it).
I've been running RabbitMQ through ProcessMonitor a fair amount to try
to discover these things (haven't found the service log yet either
with the magic cookies, but I haven't tried too hard yet).  I would
not have gotten anywhere near finding the required patches to the
previous version's startup scripts without tracing through the

I must admit though that (not trying to strike back at an obvious
hardworking bunch here) from rabbitmq to orbited getting a comet
server has been almost like pulling teeth in from the perspective of
someone just trying to get a simple solution running.  It took me
almost two weeks trying to get rabbitmq-c compiled and running the
wiretest example under MSVC for instance.  I'm just hoping that I'm
almost there now, was starting to document how to do this for the

> Best wishes,
> Matthew

Thank you for the fast response :-)

More information about the rabbitmq-discuss mailing list