[rabbitmq-discuss] BasicPublish() from .NET client hangs after upgrading server to 1.7.1

Ergeerts Glenn glenn.ergeerts at artesis.be
Thu Jan 28 12:53:03 GMT 2010

It Looks like there is a problem indeed.. This is in rabbit.log after starting:

=INFO REPORT==== 28-Jan-2010::13:46:39 ===
Memory limit set to 0MB.

=INFO REPORT==== 28-Jan-2010::13:46:39 ===
vm_memory_high_watermark set. Memory used:5285360 allowed:-663552

=INFO REPORT==== 28-Jan-2010::13:46:39 ===
    alarm_handler: {set,{vm_memory_high_watermark,[]}}

I tried manually setting the memory limit using the config file and the link you provided (I was using an empty config before),
but it doesn't seem to change anything, still the same output. I'm probably doing something wrong here..

About the startup script: it is the 1.7.1 script indeed. The error i get is:
\RabbitMQ\rabbitmq_server-1.7.1\sbin\..\ebin\rabbit was unexpected at this time.

I'm running on windows 7 64bit.


-----Oorspronkelijk bericht-----
Van: Matthias Radestock [mailto:matthias at lshift.net]
Verzonden: donderdag 28 januari 2010 12:40
Aan: Ergeerts Glenn
CC: rabbitmq-discuss at lists.rabbitmq.com
Onderwerp: Re: [rabbitmq-discuss] BasicPublish() from .NET client hangs after upgrading server to 1.7.1


glenner wrote:
> After upgrading the server to 1.7.1 my client hangs forever on the
> BasicPublish() line using the following code.

That's probably due to the improved memory monitoring telling the
producers to pause in order to prevent the server from running out of
memory. Do you see any alarms in the rabbit.log?

See http://www.rabbitmq.com/extensions.html#memsup for instructions on
how to adjust the memory limits.

> Another unrelated issue: i had to add quotes to the following line in
> rabbitmq-server.bat to get the script running:
> changed to :    set RABBITMQ_BOOT_FILE="%RABBITMQ_EBIN_ROOT%\rabbit"

Really? Even in the 1.7.1 script? What error do you get?



More information about the rabbitmq-discuss mailing list