[rabbitmq-discuss] error message trying to start stomp adapter?

Erik Anderson erikba at odysseus.anderson.name
Wed Jan 27 22:33:40 GMT 2010

I'm trying to write up instructions on how I got all this rabbitmq /
orbited / stomp running while installing this on our production server
and this time things don't seem to be working properly.  The
configuration files have changed a bit from the last time I've noticed
(upgraded from 1.7.0 to 1.7.1 on windows?)  This is the error message
that I'm getting, any obvious translation to the config entry I'm
doing wrong?

starting STOMP Adapter (binding to [{"",61613}])  ...{"Kernel

I'm getting this no matter what stomp_listeners entry I put in (or
even with no config at all) I still get this same error.

I have noticed that the "TCP Listeners" line takes longer to startup
with this version of RabbitMQ than the previous version did, even
before I ran rabbitmq-activate-plugins.bat, is that affecting this at

These are the build commands that I used to get this built (on the
linux box in my office, once I downloaded all the dependent packages):

cd ~/rabbit/v1.7.1
ln -s rabbitmq-codegen-c73ecfc91be3 rabbitmq-codegen
ln -s rabbitmq-erlang-client-825eceaca84c rabbitmq-erlang-client
ln -s rabbitmq-public-umbrella-d1a272b28e90 rabbitmq-public-umbrella
ln -s rabbitmq-server-90e101fd8b67 rabbitmq-server
ln -s rabbitmq-stomp-da7859ff22c6 rabbitmq-stomp
ln -s rabbitmq-public-umbrella/include.mk
ln -s rabbitmq-erlang-client/dist/rabbit_common
ln -s rabbitmq-stomp/dist/rabbit_stomp.ez ../rabbit_stomp-1.7.1.ez
make -C rabbitmq-server
make -C rabbitmq-erlang-client
make -C rabbitmq-stomp

I'm guessing that either a lot more info is required, I need to drop
back down to 1.7.0, or I need to sit tight for a couple of days?  Is
"tip" the place I should be getting rabbitmq-stomp from?

More information about the rabbitmq-discuss mailing list