[rabbitmq-discuss] Flow Control in RabbitMQ 1.5.3

Chris Pettitt cpettitt at gmail.com
Mon Mar 23 21:31:18 GMT 2009

Hi Matthias,

Thank you for the pointer. I should have looked more closely at the

Cursory testing reveals that RabbitMQ is able to use flow control
without crashing with a high watermark of 0.7, while 0.75 or higher
results in the Erlang node crashing (before memsup detects the low
memory condition?). I'll follow up if I learn anything more about
memsup's behavior on Solaris.


On Mon, Mar 23, 2009 at 1:14 PM, Matthias Radestock <matthias at lshift.net> wrote:
> Chris,
> Chris Pettitt wrote:
>> I found an article that talks about flow control in RabbitMQ 1.5.0
>> [1]. It doesn't seem to work in our 1.5.3 setup. When I start rabbit
>> from erl, I see that the memsup app is not started. I checked the
>> rabbitmq-server configuration and see "-os_mon start_memsup false".
>> I've tried setting start_memsup to true and I've also tried starting
>> memsup manually before calling rabbit:start(). Neither seems to cause
>> flow control information to be logged and both still result in the
>> erlang node crashing.
>> I very strongly suspect user error, but I'd appreciate some guidance
>> on how to enable this feature.
> See http://www.rabbitmq.com/admin-guide.html#memsup - you are supposed to be
> using "-rabbit memory_alarms true".  Enabling memsup the way you did should
> be ok too though as long the server isn't low on memory to start with and
> you wait at least a minute before stressing it. You may need to tweak the
> threshold. Also, we don't know whether memsup on Solaris is producing the
> right information, which is why rabbit leaves it turned off by default on
> that platform. So if you can do some testing/investigation that would be
> great.
> Matthias.

More information about the rabbitmq-discuss mailing list