[rabbitmq-discuss] Flow Control in RabbitMQ 1.5.3

Matthias Radestock matthias at lshift.net
Mon Mar 23 20:14:11 GMT 2009


Chris Pettitt wrote:
> I found an article that talks about flow control in RabbitMQ 1.5.0
> [1]. It doesn't seem to work in our 1.5.3 setup. When I start rabbit
> from erl, I see that the memsup app is not started. I checked the
> rabbitmq-server configuration and see "-os_mon start_memsup false".
> I've tried setting start_memsup to true and I've also tried starting
> memsup manually before calling rabbit:start(). Neither seems to cause
> flow control information to be logged and both still result in the
> erlang node crashing.
> I very strongly suspect user error, but I'd appreciate some guidance
> on how to enable this feature.

See http://www.rabbitmq.com/admin-guide.html#memsup - you are supposed 
to be using "-rabbit memory_alarms true".  Enabling memsup the way you 
did should be ok too though as long the server isn't low on memory to 
start with and you wait at least a minute before stressing it. You may 
need to tweak the threshold. Also, we don't know whether memsup on 
Solaris is producing the right information, which is why rabbit leaves 
it turned off by default on that platform. So if you can do some 
testing/investigation that would be great.


More information about the rabbitmq-discuss mailing list