[rabbitmq-discuss] Flow Control in RabbitMQ 1.5.3

Chris Pettitt cpettitt at gmail.com
Mon Mar 23 18:45:55 GMT 2009


I've been performance/stress testing RabbitMQ in our perf lab. We've
found that we can consistently crash RabbitMQ's erlang node (running
on Solaris) when using 2 or more producers, which send messages as
fast as they can, with 2 or more consumers. The crashes occur during
memory allocation.

I found an article that talks about flow control in RabbitMQ 1.5.0
[1]. It doesn't seem to work in our 1.5.3 setup. When I start rabbit
from erl, I see that the memsup app is not started. I checked the
rabbitmq-server configuration and see "-os_mon start_memsup false".
I've tried setting start_memsup to true and I've also tried starting
memsup manually before calling rabbit:start(). Neither seems to cause
flow control information to be logged and both still result in the
erlang node crashing.

I very strongly suspect user error, but I'd appreciate some guidance
on how to enable this feature.

[1]: http://hopper.squarespace.com/blog/2008/11/9/flow-control-in-rabbitmq.html


More information about the rabbitmq-discuss mailing list