[rabbitmq-discuss] Issue deleting Queue

Chris Nicel Chris.Nicel at 15below.com
Mon Apr 14 11:53:30 BST 2014

Hi All,

A little back ground. We're using highly available queues in a two node cluster running on Ubuntu 12.04LTS and RAbbitMQ server 3.2.2. The ha policy is set to automatically mirror each queue to the other node for failover. Our application code handles the failover and is aware of both rabbit servers.

I am having trouble deleting a queue in a vhost. The queue name contains some special chars which may be causing the management plugin some troubles when displaying the queue information. When I click on the queue name in the management plugin I get the following error message:

Not found
The object you clicked on was not found; it may have been deleted on the server.

Queue name is: Applications_Pasngr_Events_Contract_Messages+DataSourceChange:Applications_Pasngr_Events_Contract<https://dev.zorrillo.net/monitoring/rabbitmq/#/queues/zorrillo.applications.pasngr/Zorrillo_Applications_Pasngr_Events_Contract_Messages%2BDataSourceChange%3AZorrillo_Applications_Pasngr_Events_Contract>

I suspect it is the + that is the problem. If someone can help me delete it I promise not to make another queue with a + in.... Which was probably a silly idea in the first place...

I have tried rabbitmqctl but that doesn't have any delete queues options. I have also tried rabbitmqadmin python script (from http://brokerurl:15672/cli) with the command line (both with and without the quotes):

python rabbitmqadmin -V applications.pasngr delete queue name="Applications_Pasngr_Events_Contract_Messages+DataSourceChange: Applications_Pasngr_Events_Contract"

The command line returns saying that the queue has been deleted but looking at the management plugin it appears to be only deleted from one node. (management plugin shows a red +1 indicating it's not mirrored). The HA policy appears to immediately recreate the deleted queue from the other node. I have tried deleting the queue from both nodes in the same way but I can't seem to do it synchronously enough to make it actually disappear.

Any help would be greatly appreciated.


Chris Nicel
Senior Systems Engineer
15below ltd : 15below Australia pty. ltd.

t:        +44 1273 764230
e:       chris.nicel at 15below.com<mailto:chris.nicel at 15below.com>
w:      15below.com<http://www.15below.com/>
[cid:image001.png at 01CF57D8.27B5EBE0]       @15below_travel<https://twitter.com/#!/15below_travel>

15below Limited: Company registered in England and Wales No 3945289
Registered Office: Lyndean House, 43-46 Queens Road, Brighton BN1 3XB, United Kingdom

15below Australia Pty Limited: ABN 25 132 716 379
Level 21, Tower 2 Darling Park, 201 Sussex Street, Sydney, NSW 2000, Australia

Please think about the environment before printing this email.

This email and any attachments may be confidential and/or legally privileged and are solely for the use of the intended recipient. If you have received this email in error please contact the sender. Any views or opinions expressed within this e-mail are solely those of the sender, and do not necessarily represent those of 15below unless otherwise specifically stated. Although 15below has taken every reasonable precaution to ensure that any attachment to this e-mail has been checked for viruses, it is strongly recommended that you carry out your own virus check before opening any attachment, as we cannot accept liability for any damage sustained as a result of software virus infection.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140414/81f6e07c/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 808 bytes
Desc: image001.png
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140414/81f6e07c/attachment.png>

More information about the rabbitmq-discuss mailing list