[rabbitmq-discuss] RabbitMQ connection(s) Blocking !

Simon MacMullen simon at rabbitmq.com
Fri May 31 17:21:02 BST 2013

On 31/05/13 12:59, tluck wrote:
> I installed/configured RabbitMQ on multiple servers and for couple of weeks
> everything was working fine. But, recently while adding new messages to the
> queues I noticed a connection(s) blocking issue and when I ran `rabbitmqctl
> set_vm_memory_high_watermark 0.6` command then all servers start to work.
> Can anybody help me to know why I'd this issue on my servers ?

The memory alarm presumably went off; something was causing RabbitMQ's 
memory use to exceed 40% of the physical memory available. Normally we 
would expect memory use to drop after the alarm went off as messages are 
paged out / consumed, see http://www.rabbitmq.com/memory.html

> As I read
> somewhere this is a memory related issue. How could this be possible ?
> because queues were already empty  and I tried to add just 100 new messages
> into queues. which thing was consuming RMQ default allocated memory ?

See http://www.rabbitmq.com/memory-use.html for how to find out where 
memory is going in your Rabbit.

Cheers, Simon

Simon MacMullen
RabbitMQ, Pivotal

More information about the rabbitmq-discuss mailing list