[rabbitmq-discuss] RabbitMQ connection(s) Blocking !

tluck tilak.chauhan at ymail.com
Fri May 31 13:04:10 BST 2013


I installed/configured RabbitMQ on multiple servers and for past couple of
weeks everything was working fine. But, recently while adding new messages
to the queues I noticed a connection(s) blocking issue and when I ran
`rabbitmqctl set_vm_memory_high_watermark 0.6` command then all servers
start to work. Can anybody help me to know why I'd this issue on my servers
? As I read somewhere this is a memory related issue. How could this be
possible ? because queues were already empty  and I tried to add just 100
new messages into queues. So which thing was consuming default allocated
memory to RMQ ? Is there anything I can do in my script to never get stuck
into such issues ?

I'm using Rabbitmq 3.0.4 and also have clustering configured on severs.


View this message in context: http://rabbitmq.1065348.n5.nabble.com/RabbitMQ-connection-s-Blocking-tp27114.html
Sent from the RabbitMQ mailing list archive at Nabble.com.

More information about the rabbitmq-discuss mailing list