[rabbitmq-discuss] RabbitMQ connection(s) Blocking !

tluck tilak.chauhan at ymail.com
Fri May 31 12:59:57 BST 2013


I installed/configured RabbitMQ on multiple servers and for couple of weeks
everything was working fine. But, recently while adding new messages to the
queues I noticed a connection(s) blocking issue and when I ran `rabbitmqctl
set_vm_memory_high_watermark 0.6` command then all servers start to work.
Can anybody help me to know why I'd this issue on my servers ? As I read
somewhere this is a memory related issue. How could this be possible ?
because queues were already empty  and I tried to add just 100 new messages
into queues. which thing was consuming RMQ default allocated memory ? Is
there anything I can in my script to never get stuck into such issue ?

I'm using Rabbitmq 3.0.4 and also configured clustering on severs.


View this message in context: http://rabbitmq.1065348.n5.nabble.com/RabbitMQ-connection-s-Blocking-tp27113.html
Sent from the RabbitMQ mailing list archive at Nabble.com.

More information about the rabbitmq-discuss mailing list