[rabbitmq-discuss] Unable to start rabbitmq-server on a fresh installed server

Steven Yue jincheker at gmail.com
Fri May 31 15:44:40 BST 2013


Hi, everyone

I'm trying to install rabbitmq-server on my VPS server. The server is 
running newly fresh installed Ubuntu 12.04, and the rabbitmq is installed 
from APT repository.

The console shows this information:

* Starting message broker rabbitmq-server
* FAILED - check /var/log/rabbitmq/startup_\{log, _err\}


And I check the log file, it shows this:

ERROR: node with name "rabbit" already running on "mydomain"

DIAGNOSTICS
===========

nodes in question: [[email protected] mydomain]

hosts, their running nodes and ports:
- mydomain: [{rabbit,56948}]

current node details:
- node name: [email protected] mydomain
- home dir: /var/lib/rabbitmq
- cookie hash: AfrR2Uw6t3aBV6UMzo2KHA==

When I run 'ps aux | grep rabbit', I get this:

rabbitmq  5607  0.0  0.0   7416   316 ?        S    14:55   0:00 
/usr/lib/erlang/erts-5.8.5/bin/epmd -daemon

I tried to stop the server, by running:

sudo rabbitmqctl stop

And it show: Error: unable to connect to node [email protected] mydomain: nodedown

I've tried to google this problem, and followed those instructions in the 
following posts, but still couldn't get any luck:
http://stackoverflow.com/questions/8737754/node-with-name-rabbit-already-running-but-also-unable-to-connect-to-node
http://stackoverflow.com/questions/10347751/rabbitmq-refusing-to-start

I want to know why this happens on a newly install server? And can anyone 
help me out to solve this?

Thanks

Steven
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130531/968eb71d/attachment.htm>


More information about the rabbitmq-discuss mailing list