[rabbitmq-discuss] AMQP protocol version mismatch

Gordon Sim gsim at redhat.com
Wed Aug 29 12:36:17 BST 2012

On 08/29/2012 10:39 AM, Paolo wrote:
> I have installed and configured RabbitMQ-server-2.8.6-1 on ubuntu 10.04.
> My java web application successfully connects using the library which is
> included in RabbitMQ-java-client-bin-2.8.6.
> I repeated the same installation and configuration on centos 6.3.
> When the java application tries to connect to the server rabbit, takes
> the error:
> "com.rabbitmq.client.MalformedFrameException: AMQP protocol version
> mismatch, we are version 0-9-1, server sent signature 1,1,0,10"
> I tried the same configuration on Ubuntu  and onCentos with
> RabbitMQ-server-2.7.1-1 and with the library AMQP-client-2.7.1.jar. The
> behavior is the same: it works on ubuntu but I have the same error
> message on centos
> someone can give me some indication about ?

My guess is that on centos you have a Qpid server running on the 5672 
port, rather than RabbitMQ (they speak different versions of the 
protocol). If you stop the qpidd service and start RabbitMQ you should 
be fine.

More information about the rabbitmq-discuss mailing list