[rabbitmq-discuss] AMQP protocol version mismatch

Paolo paolocruciani at gmail.com
Wed Aug 29 10:39:06 BST 2012

 I have installed and configured RabbitMQ-server-2.8.6-1 on ubuntu 10.04. My
java web application successfully connects using the library which is
included in RabbitMQ-java-client-bin-2.8.6.
I repeated the same installation and configuration on centos 6.3.
When the java application tries to connect to the server rabbit, takes the
"com.rabbitmq.client.MalformedFrameException: AMQP protocol version mismatch
, we are version 0-9-1, server sent signature 1,1,0,10"

I tried the same configuration  on Ubuntu  and on Centos with RabbitMQ
-server-2.7.1-1 and with the library AMQP-client-2.7.1.jar. The behavior is
the same: it works on ubuntu but I have the same error message on centos

someone can give me some indication about ?
Thank you on advance
best regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120829/8723755b/attachment.htm>

More information about the rabbitmq-discuss mailing list