[rabbitmq-discuss] AMQP protocol version mismatch

Paolo paolocruciani at gmail.com
Wed Aug 29 14:11:37 BST 2012

Thanks for your prompt response.
Maybe i explained wrong, the RabbitMQ server works fine: I can also use the
plugin rabbitmq_management and view all active queues.
My problem is different, my application uses a library AMQP-client.jar
to communicate
with the server rabbit (AMQP-client-2.7.1.jar or AMQP-client-2.8.6.jar
on the version of server).
Using this library trying to connect to the server rabbit, i get the error
"*com.rabbitmq.client.MalformedFrameException: AMQP protocol version
mismatch* *, we are version 0-9-1, server sent signature 1,1,0,10**. *"
It seems that the client is incompatible with the server ... which is not
true because they interact properly with Ubuntu

On Wed, Aug 29, 2012 at 1:36 PM, Gordon Sim <gsim at redhat.com> wrote:

> On 08/29/2012 10:39 AM, Paolo wrote:
>> I have installed and configured RabbitMQ-server-2.8.6-1 on ubuntu 10.04.
>> My java web application successfully connects using the library which is
>> included in RabbitMQ-java-client-bin-2.8.**6.
>> I repeated the same installation and configuration on centos 6.3.
>> When the java application tries to connect to the server rabbit, takes
>> the error:
>> "com.rabbitmq.client.**MalformedFrameException: AMQP protocol version
>> mismatch, we are version 0-9-1, server sent signature 1,1,0,10"
>> I tried the same configuration on Ubuntu  and onCentos with
>> RabbitMQ-server-2.7.1-1 and with the library AMQP-client-2.7.1.jar. The
>> behavior is the same: it works on ubuntu but I have the same error
>> message on centos
>> someone can give me some indication about ?
> My guess is that on centos you have a Qpid server running on the 5672
> port, rather than RabbitMQ (they speak different versions of the protocol).
> If you stop the qpidd service and start RabbitMQ you should be fine.
> ______________________________**_________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.**rabbitmq.com<rabbitmq-discuss at lists.rabbitmq.com>
> https://lists.rabbitmq.com/**cgi-bin/mailman/listinfo/**rabbitmq-discuss<https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120829/1dedc026/attachment.htm>

More information about the rabbitmq-discuss mailing list