[rabbitmq-discuss] Unable to get management plugins working with Nagios after upgrade: "Access Refused"

Simon MacMullen simon at rabbitmq.com
Wed Sep 7 10:55:43 BST 2011

On 07/09/11 10:41, ronocgly wrote:
> Hi,
> I have upgraded my rabbitmq-server and rabbitmq management plugins to
> 2.6.0 (old version 2.2.0) , since the upgrade rabbitmq is working fine
> but nagios reports "Access Refused" when polling the plugins.

I think you're seeing the same issue reported here:


Sorry about this, I didn't think changing the realm name would break 
things. I won't change it again :)

> But I can see when I do a wget from the nagios server to the rabbitmq-
> server, first of all a "401 Unauthorized" appears then the wget works,
> its like as if there isdouble authentication happening and it fails on
> the first attempt (which does not happen on the old version of
> rabbitmq-server&  plugins)

Umm, isn't that how HTTP authentication works?

>  From what I have been reading and a colleague mention he had a problem
> with the Authentication Realm before, could it be related to that?

Yes, sounds like it.

Cheers, Simon

Simon MacMullen
RabbitMQ, VMware

More information about the rabbitmq-discuss mailing list