[rabbitmq-discuss] rabbitmq-server doesn't seem to read my cluster config file

Matthias Radestock matthias at rabbitmq.com
Thu Nov 25 20:32:17 GMT 2010

Erwan, Mark,

Erwan wrote:
> Here is my config /etc/rabbitmq/rabbitmq_cluster.config :
> ['rabbit at server-172160237','rabbit at server-172160224']

The contents of the rabbitmq_cluster.config file got moved into the
general rabbitmq.config file a few versions ago. See the current
instructions at http://www.rabbitmq.com/clustering.html#auto-config

Mark Lui wrote:
> However using the auto-configuration sections of the docs has not
> worked.
> I tried adding
> [ {rabbit, [ {cluster_nodes, ['rabbit at rabbit1', 'rabbit at rabbit2']} 
> ]}, ].
> to the rabbitmq.config file and got a syntax error.

That's a typo in the docs. Sorry. Fixed now.

> Then tried [ {rabbit, [ {cluster_nodes, ['rabbit at rabbit1',
> 'rabbit at rabbit2']} ]} ].
> removing the comma and it did not cluster.

That should work. You did copy the rabbitmq.config file onto both nodes, 
right? What does 'rabbitmqctl status' return on the individual nodes?



More information about the rabbitmq-discuss mailing list