[rabbitmq-discuss] rabbitmq-server doesn't seem to read my cluster config file

Mark Lui dr.mark.lui at gmail.com
Thu Nov 25 19:53:20 GMT 2010

I have been running into the same issue.  Clustering works fine using
the clustering transcript in the doc e.g.,

rabbit2$ rabbitmqctl stop_app
Stopping node rabbit at rabbit2 ...done.
rabbit2$ rabbitmqctl reset
Resetting node rabbit at rabbit2 ...done.
rabbit2$ rabbitmqctl cluster rabbit at rabbit1
Clustering node rabbit at rabbit2 with [rabbit at rabbit1] ...done.
rabbit2$ rabbitmqctl start_app
Starting node rabbit at rabbit2 ...done.


However using the auto-configuration sections of the docs has not worked.

I tried adding

  {rabbit, [
  	{cluster_nodes, ['rabbit at rabbit1', 'rabbit at rabbit2']}

to the rabbitmq.config file and got a syntax error.  Then tried

  {rabbit, [
  	{cluster_nodes, ['rabbit at rabbit1', 'rabbit at rabbit2']}

removing the comma and it did not cluster.  Then tried

['rabbit at rabbit1', 'rabbit at rabbit2']

in the rabbitmq_cluster.config file and it did not cluster.

I am at a lost as to what I am doing wrong.  We would like to use the
auto-configuration for an easier CM deployment.  Any insight as what
is wrong would be appreciated.


On Thu, Nov 25, 2010 at 11:43 AM, Erwan <joserwan at gmail.com> wrote:
> Hello,
> I'm trying  to configure a 2 nodes cluster setup. It works if I add a node
> with rabbitmqctl cluster rabbit at server, but it doesn't if I use a config
> file.
> Here is my config /etc/rabbitmq/rabbitmq_cluster.config :
> ['rabbit at server-172160237','rabbit at server-172160224']
> /etc/hosts is set up :
> (...)
> server-172160237
> server-172160224
> When I start rabbit-mq server, I have no error, and rabbitmq status returns
> :
> Status of node 'rabbit at server-172160237' ...
> [{running_applications,[{rabbit,"RabbitMQ","2.1.1"},
>                         {os_mon,"CPO  CXC 138 46","2.1.8"},
>                         {sasl,"SASL  CXC 138 11",""},
>                         {mnesia,"MNESIA  CXC 138 12","4.4.7"},
>                         {stdlib,"ERTS  CXC 138 10","1.15.5"},
>                         {kernel,"ERTS  CXC 138 10","2.12.5"}]},
>  {nodes,[{disc,['rabbit at server-172160237']}]},
>  {running_nodes,['rabbit at server-172160237']}]
> ...done.
> I even tried to pass config file as environment variable :
> RABBITMQ_CLUSTER_CONFIG_FILE=/etc/rabbitmq/rabbitmq_cluster rabbitmq-server
> and
> RABBITMQ_CLUSTER_CONFIG_FILE=/etc/rabbitmq/rabbitmq_cluster.config
> rabbitmq-server
> But same result, except that rabbit has been replaced by toto ...
> Do you see something I may have done wrong ?
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list