[rabbitmq-discuss] rabbitmq-server doesn't seem to read my cluster config file

Erwan joserwan at gmail.com
Thu Nov 25 19:43:11 GMT 2010


I'm trying  to configure a 2 nodes cluster setup. It works if I add a node
with rabbitmqctl cluster rabbit at server, but it doesn't if I use a config

Here is my config /etc/rabbitmq/rabbitmq_cluster.config :

['rabbit at server-172160237','rabbit at server-172160224']

/etc/hosts is set up :

(...) server-172160237 server-172160224

When I start rabbit-mq server, I have no error, and rabbitmq status returns

Status of node 'rabbit at server-172160237' ...
                        {os_mon,"CPO  CXC 138 46","2.1.8"},
                        {sasl,"SASL  CXC 138 11",""},
                        {mnesia,"MNESIA  CXC 138 12","4.4.7"},
                        {stdlib,"ERTS  CXC 138 10","1.15.5"},
                        {kernel,"ERTS  CXC 138 10","2.12.5"}]},
 {nodes,[{disc,['rabbit at server-172160237']}]},
 {running_nodes,['rabbit at server-172160237']}]

I even tried to pass config file as environment variable :

RABBITMQ_CLUSTER_CONFIG_FILE=/etc/rabbitmq/rabbitmq_cluster rabbitmq-server

But same result, except that rabbit has been replaced by toto ...

Do you see something I may have done wrong ?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20101125/0da28624/attachment.htm>

More information about the rabbitmq-discuss mailing list