[rabbitmq-discuss] hg version of RabbitMQ does not "make install" at Ubuntu 10.4

Willi Richert w.richert at gmx.net
Tue Jun 8 14:29:46 BST 2010


my preferred installation would indeed be a local one - so that 
everything is kept in one directory like /opt/proj-rabbitmq .

Regarding the "plugins" directory: Maybe you just mention that that 
directory should be created manually at 


On 08.06.2010 15:08, Matthew Sackman wrote:
> Hi,
> On Tue, Jun 08, 2010 at 03:00:34PM +0200, Willi Richert wrote:
>> When I do "sudo make install" I get the following error:
>> mkdir -p
>> mkdir: missing operand
> Hmm. It's possible the "make install" target is broken - we don't run it
> much and it doesn't get a great deal of love and attention from us. It
> should first check that certain variables are defined, but it looks like
> its prereqs manage to skip over those tests. Sigh. I'll raise a bug to
> get it fixed.
> Try defining SBIN_DIR, MAN_DIR and TARGET_DIR as variables. If you
> really want it installed system wide, something like:
> make install SBIN_DIR=/usr/sbin TARGET_DIR=/var/lib/rabbitmq-server MAN_DIR=/usr/local/man
> might work.
> Matthew
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> http://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list