[rabbitmq-discuss] RabbitMQ + Stomp under FC9

Tony Garnock-Jones tonyg at lshift.net
Thu Apr 30 18:25:40 BST 2009

Hi David,

What you describe is really odd -- and unfortunately, it actually works
OK for me:

hg clone http://hg.rabbitmq.com/rabbitmq-codegen
hg clone http://hg.rabbitmq.com/rabbitmq-server
hg clone http://hg.rabbitmq.com/rabbitmq-stomp
(cd rabbitmq-codegen; hg up rabbitmq_v1_5_3)
(cd rabbitmq-server; hg up rabbitmq_v1_5_3)
(cd rabbitmq-stomp; hg up rabbitmq_v1_5_3)
make -C rabbitmq-server
make -C rabbitmq-stomp run

Then in another terminal,

Then in another terminal, every call I make to
rabbitmq-stomp/examples/perl/rabbitmq_stomp_send.pl makes "testmessage"
appear on the console running the _recv.pl script.

It's especially odd that you can connect and everything seems to run
fine. Is there anything interesting in the rabbit.log file?

(Also worth checking: did you run the receiver before running the
sender? I think (?) the receiver needs to be running at the time the
sender runs)


David Cawley wrote:
> I've been testing out several Message Queues under Redhat FC9
> using Stomp e.g. POE based MQ and ActiveMQ. I also wanted to
> try RabbitMQ but I'm unable to receive messages from the queue?
> I see that Tony from lshift has been busy answering questions and
> fixing issues so I'm hoping it's in a usable state.
> I installed the rabbitmq-server-1.5.3-1 via yum (I had to manually create
> a rabbitmq user/group and home directory for a cookie). I then compiled
> the stomp adaptor as follows using the rabbitmq_v1_5_3 tag :
> cd /usr/lib/erlang/lib/
> hg clone http://hg.rabbitmq.com/rabbitmq-stomp
> cd rabbitmq-stomp
> hg update rabbitmq_v1_5_3
> make RABBIT_SERVER_SOURCE_ROOT=../rabbitmq_server-1.5.3
> I created a config file so that the stomp adaptor is used:
> /etc/rabbitmq/rabbitmq.conf
>       -pa /usr/lib/erlang/lib/rabbitmq-stomp/ebin
>       -rabbit
>          stomp_listeners [{"",61613}]
>          extra_startup_steps
> [{"STOMP-listeners",rabbit_stomp,kickstart,[]}]'
> I restarted the rabbitmq-server process and I can connect to port 61613.
> The stomp
> connect works. However, when I run the example perl test scripts I don't
> receive any
> of the messages. The rabbit.log file indicates the accepting of the TCP
> connection
> and starting and sending of Stomp connection and no errors. I also tried
> using the ruby
> examples but still no luck. I even tried doing the process above with
> the latest 1.5.4
> mq-server rpm with the v1_5_3 tagged rabbitmq-stomp. How can I get it
> working?
> ./examples/perl/rabbitmq_stomp_send.pl
> ./examples/perl/rabbitmq_stomp_recv.pl
> Thanks,
> David
> ------------------------------------------------------------------------
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> http://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

 [][][] Tony Garnock-Jones     | Mob: +44 (0)7905 974 211
   [][] LShift Ltd             | Tel: +44 (0)20 7729 7060
 []  [] http://www.lshift.net/ | Email: tonyg at lshift.net

More information about the rabbitmq-discuss mailing list