[rabbitmq-discuss] RabbitMQ + Stomp under FC9

David Cawley daviddcawley at gmail.com
Mon Apr 20 04:35:13 BST 2009

I've been testing out several Message Queues under Redhat FC9
using Stomp e.g. POE based MQ and ActiveMQ. I also wanted to
try RabbitMQ but I'm unable to receive messages from the queue?
I see that Tony from lshift has been busy answering questions and
fixing issues so I'm hoping it's in a usable state.

I installed the rabbitmq-server-1.5.3-1 via yum (I had to manually create
a rabbitmq user/group and home directory for a cookie). I then compiled
the stomp adaptor as follows using the rabbitmq_v1_5_3 tag :

cd /usr/lib/erlang/lib/
hg clone http://hg.rabbitmq.com/rabbitmq-stomp
cd rabbitmq-stomp
hg update rabbitmq_v1_5_3
make RABBIT_SERVER_SOURCE_ROOT=../rabbitmq_server-1.5.3

I created a config file so that the stomp adaptor is used:

      -pa /usr/lib/erlang/lib/rabbitmq-stomp/ebin
         stomp_listeners [{"",61613}]

I restarted the rabbitmq-server process and I can connect to port 61613. The
connect works. However, when I run the example perl test scripts I don't
receive any
of the messages. The rabbit.log file indicates the accepting of the TCP
and starting and sending of Stomp connection and no errors. I also tried
using the ruby
examples but still no luck. I even tried doing the process above with the
latest 1.5.4
mq-server rpm with the v1_5_3 tagged rabbitmq-stomp. How can I get it



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20090420/e6873810/attachment.htm 

More information about the rabbitmq-discuss mailing list