[rabbitmq-discuss] Windows server 2012 config file not found

Mariusz Wojcik mariusz.wojcik at hotmail.co.uk
Wed Jul 16 16:55:03 BST 2014

Hi all,

   I also had the same problem with latest versions (3.3 and 3.4). To add 
more information, it seems there is an issue when running RabbitMQ as a 
Windows Service. It works when starting up server from console. I also 
thought this could be related to permissions, so I tried giving access to 
config file to anyone and running service under different user, including 
one with admin privileges with no success. Neither setting env.setting 

   I resolved to running rabbit from console instead of Windows service. 
You can also revert to previous version (3.0 worked fine for me). 

Hope someone can shed more light on this problem.



On Wednesday, 16 July 2014 16:10:26 UTC+1, Greg Woodbury wrote:
> I am running rabbitmq on windows server 2012 and am running into a problem 
> where rabbitmq seems to be unable to locate my config file. The log 
> suggests that it is looking in the correct directory for the file, but is 
> not being found. I would normally think that this is a permissions issue, 
> but the logs are being found and written to in a subdirectory from where 
> the config file resides. Below is the log snippet showing the error and I 
> have attached a screenshot with the config file sitting in the same 
> directory.
> =INFO REPORT==== 16-Jul-2014::10:51:39 ===
> node           : rabbit@{server}
> home dir       : C:\Windows
> config file(s) : c:/Users/{user}/AppData/Roaming/RabbitMQ/rabbitmq.config 
> (not found)
> ...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140716/1ec4f7ef/attachment.html>

More information about the rabbitmq-discuss mailing list