[rabbitmq-discuss] Unable to connect to rabbit at localhost: nodedown

Michael Klishin michael.s.klishin at gmail.com
Thu Jan 16 08:45:08 GMT 2014

2014/1/16 Alex L <buzz42j at gmail.com>

> I recently stopped my rabbitmq server and tried to start it again but it
> can't reconnect for some reason.
> I killed background processes that rabbitmq was running and tried to start
> the connection again but every time I try the boot fails. I looked into the
> log file and I'm getting a timeout_waiting_for_tables error as well. I'm
> not really sure what do to next to solve this.

Has your hostname or /etc/hosts contents changed recently?

RabbitMQ database is stored in a directory that has hostname in the path.
You may need to make the two match (e.g. by renaming the directory).

See Issue With Hostname on http://www.rabbitmq.com/ec2.html
and http://www.rabbitmq.com/relocate.html

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140116/fbcbb870/attachment.html>

More information about the rabbitmq-discuss mailing list