[rabbitmq-discuss] Queue will not delete

Ganann, Kale KGanann at kroll.com
Tue Aug 26 21:13:42 BST 2014

Hmm.  Here's something interesting - I tried to overwrite it, and got this back from the api:

PS C:\Users\kganann.CCP> Write-RMQQueue -RabbitMQServer $RMQDev -Credential $Cred -vHost "master" -Name "q.d2.ha.gemini.internalIndexing"
Invoke-WebRequest : {"error":"bad_request","reason":"406 PRECONDITION_FAILED - parameters for queue
'q.d2.ha.gemini.internalIndexing' in vhost 'master' not equivalent"}
At C:\Windows\system32\WindowsPowerShell\v1.0\Modules\rabbitmq\RabbitMQ.psm1:1074 char:17
+         $RawResults = Invoke-WebRequest -Uri "http://$RabbitMQServer`:$Port/api/queues ...
+    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebExc
    + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand
ConvertFrom-Json : Cannot bind argument to parameter 'InputObject' because it is null.
At C:\Windows\system32\WindowsPowerShell\v1.0\Modules\rabbitmq\RabbitMQ.psm1:1077 char:30
+     $Results = ConvertFrom-Json $RawResults
+                                 ~~~~~~~~~~~
    + CategoryInfo          : InvalidData: (:) [ConvertFrom-Json], ParameterBindingValidationException
    + FullyQualifiedErrorId : ParameterArgumentValidationErrorNullNotAllowed,Microsoft.PowerShell.Commands.ConvertFrom

-----Original Message-----
From: rabbitmq-discuss [mailto:rabbitmq-discuss-bounces at lists.rabbitmq.com] On Behalf Of Ganann, Kale
Sent: Tuesday, August 26, 2014 3:06 PM
To: Michael Klishin; Legacy list about RabbitMQ
Subject: Re: [rabbitmq-discuss] Queue will not delete

As I said, nothing is in the log files.  The only reason you can tell I even attempted it is I show up in the access logs for the management plug in.

I have tried to delete via the management plug in and via the HTTP API.

I reported some of the issues we were having moving to 3.3 at the time, largely around (but not limited to) federation completely and totally failing for us once we moved up, but we weren't yielding great results and had to roll back for time constraints to get our environments up and running.

-----Original Message-----
From: Michael Klishin [mailto:mklishin at pivotal.io]
Sent: Tuesday, August 26, 2014 3:01 PM
To: Ganann, Kale; Legacy list about RabbitMQ
Subject: Re: [rabbitmq-discuss] Queue will not delete

 On 26 August 2014 at 23:21:49, Ganann, Kale (kganann at kroll.com) wrote:
> >
> I have a queue that won’t delete in RabbitMQ 3.2.4. When I try to 
> access it via the management plug-in, I get:
> TypeError: Cannot read property 'ram_msg_count' of undefined
> TypeError: Cannot read property 'ram_msg_count' of undefined

What is in the log files? How do you delete the queue, using a Rabbit client or HTTP API?

Staff Software Engineer, Pivotal/RabbitMQ _______________________________________________
rabbitmq-discuss mailing list has moved to https://groups.google.com/forum/#!forum/rabbitmq-users,
please subscribe to the new list!

rabbitmq-discuss at lists.rabbitmq.com

More information about the rabbitmq-discuss mailing list