[rabbitmq-discuss] Queue will not delete

Ganann, Kale KGanann at kroll.com
Tue Aug 26 20:18:13 BST 2014

Hi all,

I have a queue that won't delete in RabbitMQ 3.2.4.  When I try to access it via the management plug-in, I get:

TypeError: Cannot read property 'ram_msg_count' of undefined

TypeError: Cannot read property 'ram_msg_count' of undefined
And nothing displays.  When I try to delete it via the API, it hangs and I get a timeout.  I can list the queue via the API, but policies don't apply to the queue, and message counts show as "?" in the management plug-in.  I tried having the cluster forget the node that owned the queue, but it remained despite this.  I bypassed the VIP and connected directly to the API on the node itself, and it gave the same results.  Additionally, nothing was noted in the normal or SASL logs to denote the attempt - the only way you can even tell I was there was the access log from the management plug-in.  I ran rabbitmqctl report, and am attaching what I got, but it keeps freezing partway through, which I'm guessing is it trying to access whatever is stuck.

As always, any help you can provide is appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140826/f1cbecfb/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: report.txt
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20140826/f1cbecfb/attachment.txt>

More information about the rabbitmq-discuss mailing list