[rabbitmq-discuss] Instable HA cluster

ben.west at mobankgroup.com ben.west at mobankgroup.com
Fri Jan 25 09:52:30 GMT 2013


I've been having lots of instability problems with a rabbit cluster I have 
set up.
Since deploying Rabbit MQ a few months ago we have experienced ongoing 
instability with the service.

Our setup:

   - RabbitMQ 3.0.1 running on Windows Azure VMs (Server 2012)
   - We have 2 VMs set up with a rabbit running on each and clustered (with 
   a HA policy), both running as disk nodes
   - Using EasyNetQ for producers consumers

When I first set up the cluster everything seems to be running well and can 
see through the Rabbit console the HA mirroring is all set up.

However after a couple of days I will log into the console and find the 
cluster is broken, usually with one node saying "Node not running" and a 
number of the consumers have dropped off the queues. I then have to tear 
down the cluster and build it all up again - not a massive job, but I'm 
sure i shouldn't need to do this every week!

At first I thought it may be due to Windows updates automatically 
restarting the server and possibly breaking the cluster, but have now 
turned these off and still get the same problem. I have also tried 
rebooting the servers one at a time to test this but the cluster seems to 
pick itself back up once the reboot has finished.

I've done lots of reading online but cant seem to find too many suggestions 
so I hope someone here may be able to help.

I'm more thank happy to provide logs if these may be useful?

Any help will be grately appreciated!



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130125/12f03a1a/attachment.htm>

More information about the rabbitmq-discuss mailing list