[rabbitmq-discuss] Cannot access rabbitmqadmin.

Simon MacMullen simon at rabbitmq.com
Thu Jan 24 13:26:20 GMT 2013

Ah - so you were using "rabbitmqctl stop_app" and "rabbitmqctl 
start_app" - yes that would not work since they never halt the Erlang 
VM. "service rabbitmq-server restart" would have worked without a reboot.

I guess we should try to make that clearer.

Cheers, Simon

On 24/01/13 05:56, Alex Damian wrote:
> I finally got it working. Restarting and stopping the server with
> rabbitmqctl did not work. So I rebooted then restarted directly with the
> rabbitmq-server start command and this time it seemed to load all the
> plugins including Mochiweb and I was able to open the admin webpage. I'm
> not sure why it did not work immediately after the plugins were
> enabled...however I'm happy with this solution albeit not ideal since it
> required a reboot.
> On Tuesday, January 22, 2013 5:23:24 PM UTC-5, Alex Damian wrote:
>     Hi
>     I have followed all the instructions on
>     http://www.rabbitmq.com/management.html
>     <http://www.rabbitmq.com/management.html> and enabled the plugin,
>     but after than there is no webserver running anywhere on my machine.
>     There is no way to connect to Mochiweb at all. I have restarted the
>     service and still nothing. I have also tried the
>     "http:///server-name/:15672/" URL with "localhost", and
>     also the full server name, all of which are /etc/hosts file. My
>     vhost is the default "/". Should I add something in my config file
>     perhaps? I have also tried a /curl/ command and still nothing.
>     I am running on Fedora Core 17 with all latest libs including latest
>     rabbitMQ sw. I have checked the listening ports on the server and i
>     only see the AMQP one.
>     Also I can run rabbitmq-server and rabbitmqctl without issues. I
>     have also been able to create exchanges/queues via rabbit.js on
>     Node. However not having a proper admin tool is a bit drawback. I
>     wonder why it's not possible to supply one like (or enhance)
>     rabbitmqctl. Seems to do the job just fine.
>     Any help would be greatly appreciated!
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

Simon MacMullen
RabbitMQ, VMware

More information about the rabbitmq-discuss mailing list