[rabbitmq-discuss] Manual service stop or start via rabbitmq-service.bat on Windows has an %APPDATA% path bug.

Nick Josevski nickjosevski at gmail.com
Wed Mar 28 07:26:01 BST 2012

Hi Emile,
  Thanks for the feedback, and the clarifications, if there's
anything outstanding that's still relevant to my concern is how a new
folder with the name %APPDATA% ended up in the sbin folder. This to me
seems to be a bug with the bat scripts and I do believe it played a factor
in making the setup on my machine dysfunctional.

On Tue, Mar 27, 2012 at 9:41 PM, Emile Joubert <emile at rabbitmq.com> wrote:

> Hi Nick,
> On 27/03/12 03:05, Nick Josevski wrote:
> > I tried to enable the management web feature via rabbitmq-plugins, but
> > somewhere during the process of enabling, stopping, installing,
> > starting the service back up again. A rogue '%APPDATA%' folder was
> > created in the sbin folder. In my case C:\Program Files (x86)\RabbitMQ
> > Server\rabbitmq_server-2.8.1\sbin
> >
> > I've experienced this issue on versions 2.7.1 and 2.8.1.
> The default script folder for v2.8.1 is
> C:\Program Files\RabbitMQ Server\rabbitmq_server-2.8.1\sbin
> If you select a different installation folder (such as C:\Program Files
> (x86)) then the scripts will be installed in the folder you quoted.
> > The worst part of this is once that happened, I kept getting nodedown
> > errors when trying to do anything even via the reset and force_reset
> > commands.
> This is unlikely to be related to the installation path. Have you tried
> the advice in the troubleshooting guide?
> http://www.rabbitmq.com/troubleshooting.html
> > My solution was to uninstall RabbitMQ, delete all the folders (in
> > AppData and in Program Files), then go further to uninstall and re-
> > install Erlang, all with reboots scattered throughout to ensure
> > nothing was left behind.
> The uninstaller should do that for you. It should not be necessary to
> re-install Erlang.
> > To finally enable the rabbitmq_management plugin I had to just enable
> > it via the rabbitmq-plugins, **not** run stop or install or start via
> > rabbitmq-service.bat, but instead go into Services and just re-start
> > the RabbitMQ service via right click > start.
> This is incorrect. Restarting the broker is not sufficient for enabling
> plugins when running as a service. You must reinstall the service.
> -Emile
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20120328/4bced39f/attachment.htm>

More information about the rabbitmq-discuss mailing list