[rabbitmq-discuss] Manual service stop or start via rabbitmq-service.bat on Windows has an %APPDATA% path bug.

Emile Joubert emile at rabbitmq.com
Tue Mar 27 11:41:16 BST 2012

Hi Nick,

On 27/03/12 03:05, Nick Josevski wrote:
> I tried to enable the management web feature via rabbitmq-plugins, but
> somewhere during the process of enabling, stopping, installing,
> starting the service back up again. A rogue '%APPDATA%' folder was
> created in the sbin folder. In my case C:\Program Files (x86)\RabbitMQ
> Server\rabbitmq_server-2.8.1\sbin
> I've experienced this issue on versions 2.7.1 and 2.8.1.

The default script folder for v2.8.1 is
C:\Program Files\RabbitMQ Server\rabbitmq_server-2.8.1\sbin

If you select a different installation folder (such as C:\Program Files
(x86)) then the scripts will be installed in the folder you quoted.

> The worst part of this is once that happened, I kept getting nodedown
> errors when trying to do anything even via the reset and force_reset
> commands.

This is unlikely to be related to the installation path. Have you tried
the advice in the troubleshooting guide?

> My solution was to uninstall RabbitMQ, delete all the folders (in
> AppData and in Program Files), then go further to uninstall and re-
> install Erlang, all with reboots scattered throughout to ensure
> nothing was left behind.

The uninstaller should do that for you. It should not be necessary to
re-install Erlang.

> To finally enable the rabbitmq_management plugin I had to just enable
> it via the rabbitmq-plugins, **not** run stop or install or start via
> rabbitmq-service.bat, but instead go into Services and just re-start
> the RabbitMQ service via right click > start.

This is incorrect. Restarting the broker is not sufficient for enabling
plugins when running as a service. You must reinstall the service.


More information about the rabbitmq-discuss mailing list