[rabbitmq-discuss] 404, "NOT_FOUND - no queue 'foo' in vhost '/'"

Simon MacMullen simon at rabbitmq.com
Mon Mar 12 10:47:06 GMT 2012

On 12/03/12 10:38, Soner wrote:
> I am running a rabbit-mq (version 2.7.1) cluster with three nodes. On
> this cluster I have created a mirrored and durable queue called 'foo'
> by using the browser based management console. I also have created the
> related exchange and binding. When I tried to connect with my consumer
> and publisher I was getting following error:
> 404, "NOT_FOUND - no queue 'foo' in vhost '/'"

If you are a seeing a 404 then either:

a) if you are getting that in response to a basic.consume you have not 
created it with the name you think you have *or*
b) if you are getting that in response to a queue.declare then you 
created a non-mirrored queue on a host which is down.

> I couldn't find any solution so I have deleted the queue and created
> it again with the same setup as before. Then started the consumers
> again and it worked. Somehow strange for me that recreating the queue
> has helped.

This suggests problem a).

Cheers, Simon

Simon MacMullen
RabbitMQ, VMware

More information about the rabbitmq-discuss mailing list