[rabbitmq-discuss] Interesting Active-Active error

Jason J. W. Williams jasonjwwilliams at gmail.com
Mon Oct 24 23:52:57 BST 2011


Been messing around with mirrored queues in 2.6.1 on OS X 10.7.2
today. I initially created a queue called "hello-queue" with an
"x-ha-policy" of "all". This worked as expected. I then deleted the
queue through the management web UI and tried recreating it now with
the following arg dict:

{"x-ha-policy" : "nodes", "x-ha-policy-params" , ["rabbit at Phantome,
"rabbit2 at Phantome"]}

This triggered an AMQP 404 error when trying to create the queue:
pika.exceptions.AMQPChannelError: (404, "NOT_FOUND - no queue
'hello-queue' in vhost '/'")

I've attached the sample program. What was more curious however, is
that the web UI shows the queue existing but in some sort of broken
state, to the effect that when you try to delete the queue through the
web UI you get the same AMQP 404 error. Here is a screencast showing
the state of the queue in the web UI and the effect of trying to
delete it: http://screencast.com/t/f7PVpPflyUu4

Any pointers are greatly appreciated.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: hello_world_mirrored_queue_consumer.py
Type: application/octet-stream
Size: 1984 bytes
Desc: not available
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20111024/f5bbb21c/attachment.obj>

More information about the rabbitmq-discuss mailing list