[rabbitmq-discuss] Installation Trouble on Windows - "The handle is invalid"

Ann Witbrock (c) awitbrock at vmware.com
Wed Jul 27 11:18:21 BST 2011

Hi Chris, 
I'm sorry our troubleshooting instructions weren't able to help you. 

Does the rabbitmq service still appear in your list of services? 
Is epmd.exe still running in your processes? You may like to kill that. 
Did you make any change to the cookie or was that ok? 

It sounds like you had an older version already installed. Is that correct? 
If so, you may need to install the older version combination in order to stop and remove the old service. 
After removing the service you should be able to uninstall rabbitmq, remove directories (including mnesia and logs if you want) and uninstall erlang, and remove any environment variables you dont want (eg from path and ERLANG_HOME). 
Double check there is no RabbitMQ service present and that epmd.exe is not running. You may wish to reboot. 

After that a clean fresh install should work ok. Our "experimental" installer works quite well, just ensure you stop, remove and start the service again (or reboot) after adding plugins. Also remember you may need to run some steps as administrator (elevated permission). 


----- Original Message -----

From: "Christopher Moloney" <cmoloney at vt.edu> 
To: rabbitmq-discuss at lists.rabbitmq.com 
Sent: Wednesday, 27 July, 2011 1:16:54 AM 
Subject: [rabbitmq-discuss] Installation Trouble on Windows - "The handle is        invalid" 

I am new to rabbitmq and these sorts of messaging services. I am having trouble installing RabbitMQ on window7. I would like to use it in conjunction with django-celery to manage a task queue. 
I looked around the archives but I didn’t see anything that offered a solution to my problem. 
Here is a summary of what I have done thus far. First I installed erlang 5.8.4 and rabbitmq 2.5.1 and followed the procedure on the windows install page. Everything seemed to go well, however when I tried to run the server it continually returned node down. In the hello world example using pika I got the message that the connection was actively refused by the machine. So first I checked my firewall to make sure port 5672 was open. Then, I made sure my C:/Windows .erlang.cookie matched the on in my user directory. 
Starting the server I would get a boot error that was not very descriptive: error, badmatch error. 
So I decided to try to uninstall and run the prepackaged windows binaries. Well then there was a windows service error mismatch because I had installed erlang 5.8.4 and the windows binaries used 5.8.3.   The windows service was point to the wrong directory. Service.msc does not allow you to edit the path. I used the SC DELETE command at the terminal to remove the RabbitMQ service imaging that a fresh install would replace the service value with the correct location. 
Since then I have not been able to add the service back. When I attempt to run ‘rabbitmq-service install’ get the message: Warning, could not set correct service description (comment) Error: The handle is invalid. 
The same message comes up when I run any of the commands. I have tried to wipe all traces of erlang and rabbit from my machine to start again, but it has not been possible. I would really like to resolve this matter and get the messaging server up and running. 
Any suggestions? I appreciate any assistance. 
rabbitmq-discuss mailing list 
rabbitmq-discuss at lists.rabbitmq.com 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20110727/0f9f3727/attachment.htm>

More information about the rabbitmq-discuss mailing list