[rabbitmq-discuss] Naming RabbitMQ nodes with complete domain names

Alvaro Videla videlalvaro at gmail.com
Sat Feb 19 18:19:36 GMT 2011

Restart the epmd process or if you are just running RabbitMQ then kill it after you stop the server.

Hope that helps.

Sent from my iFad

On Feb 20, 2011, at 1:49 AM, Max Bridgewater <max.bridgewater at gmail.com> wrote:

> Hi Alvaro,
> I believe you are right. The according modification of the rabbitmq
> scripts seems not that straightforward. Here is what I've got sofar:
> a) Changed the option -sname to -name in rabbitmq-multi
> b) Changed the node name initialization in rabbitmq-env from
> NODENAME=rabbit@${HOSTNAME%%.*} to #NODENAME=rabbit@${HOSTNAME}
> c) Changed the node names in rabbitmq.config to use full host names.
> d) Cleared the mnesia database.
> Now, when I attempt to start the nodes, hereunder is what I get.
> Apparently, despite these modifications rabbitmq/erlang is still
> attempting to set the short name.
> Any idea what else I'm missing?
> Thanks,
> Max.
> ============================================
> Starting all nodes...
> Starting node rabbit at ec2-174-122-225-215.compute-1.amazonaws.com...
> Activating RabbitMQ plugins ...
> 0 plugins activated:
> {error_logger,{{2011,2,19},{12,33,32}},"Can't set short node
> name!\nPlease check your configuration\n",[]}
> On Sat, Feb 19, 2011 at 12:32 AM, Alvaro Videla <videlalvaro at gmail.com> wrote:
>> Have you tried changing the Erlang option -sname to -name?
>> That's the way Erlang uses to specify long names.
>> See http://erlang.org/doc/man/erl.html and then modify your rabbitmq-server script accordingly.
>> Cheers,
>> Alvaro
>> Sent from my iFad
>> On Feb 19, 2011, at 10:51 AM, Max Bridgewater <max.bridgewater at gmail.com> wrote:
>>> Hi,
>>> This is probably a silly question but it really baffles me right now.
>>> The original issue is this: I'm trying to use JInterface to connect to
>>> a rabbitmq cluster hosted on EC2. But I keep getting "Cannot connect
>>> to peer node". My understanding is that this error is happening
>>> because I'm using the address 'rabbit at domain.org' to contact the
>>> remote RabbitMQ node named: rabbit at domain. (Note the missing TLD).
>>> That is, because there is no exact  match between the node name given
>>> to JInterface and the name of the node it is connecting to, the
>>> connection fails.
>>> I desperately tried configuring RabbitMQ to take the complete domain
>>> name (domain.org) instead of just the short domain name (domain). Any
>>> suggestion on how to resolve this issue?
>>> Beyond this, this problem begs the question of how do RabbitMQ nodes
>>> located on different machines across different domains communicate
>>> with each other if the only way they can be referred to each other by
>>> short name? Up until now, I've only clustered nodes on the same
>>> machine.
>>> I'm sure missing something. Please enlighten me.
>>> Sincerely,
>>> Max.
>>> _______________________________________________
>>> rabbitmq-discuss mailing list
>>> rabbitmq-discuss at lists.rabbitmq.com
>>> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list