[rabbitmq-discuss] RabbitMQ refuses to start , instead crash

Marek Majkowski majek04 at gmail.com
Thu Sep 30 12:00:26 BST 2010


Right in the top of your erl_crash.dump there is an reason of the death:
Slogan: eheap_alloc: Cannot allocate 583848200 bytes of memory (of type "heap").

In future, please send us not only erl_crash.dump but also rabbit.log
and rabbit-sasl.log.

The error means that for some reason RabbitMQ was not able to allocate
 556 megs of RAM.
Do you know why it needs so much memory? Do you have a lot of data in
mnesia directory,
a large number of queues or something like that?

Further, we encourage to run Rabbit on 64 bit operating systems. Even
if you'll give
3.5 GB memory for windows VM, rabbit won't be able to use it on 32 bit system!


On Thu, Sep 23, 2010 at 20:36, Chandra R <mybayworkz at gmail.com> wrote:
> Hello,
>  I am new to rabbitmq and  I have been trying to run it on Windows XP with
> 2.5 gb on a VM (Also tried on XP with 3.5 gb on a VM) but it crashes.
> Later I found that I was using extension .conf instead of .config, which I
> corrected.
> Still it does the same thing, crashing. No logs are being created.
> I am using erlang 5.7.4 and tried rabbitmq 2.1.0 & 1.8.1.
> I have attached crash dump zip
> Please help me get started
> Thank you
> regards,
> Chandra
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list