[rabbitmq-discuss] RabbitHub installation problem

Oliver Senn oliver.senn at smart.mit.edu
Mon Sep 20 05:16:28 BST 2010

Hi list,

I just tried setting up RabbitHub under RabbitMQ 2.1.0. I managed to 
compile it but the installation does not seem to work. Here is what 
I did:
1) Downloaded and compiled the umbrella project (according to [1])
2) Downloaded the source of RabbitHub and compiled it
3) That leaves me with a 'dist' folder with the following contents
       rabbithub (folder)
4) I then copied all of the above to the plugins directory of my
    RabbitMQ installation. Was that the right thing to do?
5) Tried to start RabbitMQ but got this error message:
       Duplicated modules:
          supervisor2 specified in rabbit and rabbit_common
          gen_server2 specified in rabbit and rabbit_common
6) So I removed the rabbit_common.ez file from the plugins directory
    and restarted.
7) Then the server could be started and the following output was
    generated by rabbitmqctl status:
Status of node rabbit at satay ...
      [{amqp_client,"RabbitMQ AMQP Client","0.0.0"},
       {os_mon,"CPO  CXC 138 46","2.2.4"},
       {sasl,"SASL  CXC 138 11","2.1.8"},
       {mochiweb,"MochiMedia Web Server","1.3"},
       {inets,"INETS  CXC 138 49","5.2"},
       {crypto,"CRYPTO version 1","1.6.3"},
       {rabbit_mochiweb,"RabbitMQ Mochiweb Embedding","0.0.0"},
       {mnesia,"MNESIA  CXC 138 12","4.4.12"},
       {stdlib,"ERTS  CXC 138 10","1.16.4"},
       {kernel,"ERTS  CXC 138 10","2.13.4"}]},
  {nodes,[{disc,[rabbit at satay]}]},
  {running_nodes,[rabbit at satay]}]

So the rabbithub and mochiweb modules are there.

8) But access to http://localhost:8000 was not possible

Any idea what I did wrong?

Thanks for ideas / help :-)



[1] http://www.rabbitmq.com/plugin-development.html#getting-started

More information about the rabbitmq-discuss mailing list