[rabbitmq-discuss] BasicPublish() from .NET client hangs after upgrading server to 1.7.1

David Wragg david.wragg at lshift.net
Thu Jan 28 17:11:46 GMT 2010

Hi Glenn,

Ergeerts Glenn <glenn.ergeerts at artesis.be> writes:
> I tried manually setting the memory limit using the config file and
> the link you provided (I was using an empty config before), but it
> doesn't seem to change anything, still the same output. I'm probably
> doing something wrong here..
> About the startup script: it is the 1.7.1 script indeed. The error i
> get is: \RabbitMQ\rabbitmq_server-1.7.1\sbin\..\ebin\rabbit was
> unexpected at this time.
> I'm running on windows 7 64bit.

I'm attempting to reproduce this problem, but without success so far.

The error message suggests that you have tried to install plugins.  Is
that correct?

Here's what I'm doing.  I'm on Windows 7 32-bit.

- I downloaded rabbitmq-server-windows-1.7.1.zip, and expanded it
  under c:\program files.

- Attempting to reproduce plugins installation, in a cmd window,
  started with "Run as Administator", I did:

C:\Program Files\RabbitMQ\rabbitmq_server-1.7.1>sbin\rabbitmq-activate-plugins.bat

- Then in a normal cmd window, I ran rabbitmq-server.  As you can see,
  it was successful:

C:\Program Files\RabbitMQ\rabbitmq_server-1.7.1>sbin\rabbitmq-server.bat
Using Custom Boot File "C:\Program Files\RabbitMQ\rabbitmq_server-1.7.1\sbin\..\ebin\rabbit.boot"

+---+   +---+
|   |   |   |
|   |   |   |
|   |   |   |
|   +---+   +-------+
|                   |
| RabbitMQ  +---+   |
|           |   |   |
|   v1.7.1  +---+   |
|                   |
AMQP 8-0
Copyright (C) 2007-2009 LShift Ltd., Cohesive Financial Technologies LLC., and R
abbit Technologies Ltd.
Licensed under the MPL.  See http://www.rabbitmq.com/

node          : rabbit at win7
app descriptor: c:/Program Files/RabbitMQ/rabbitmq_server-1.7.1/sbin/../ebin/rabbit.app
home dir      : C:\Users\Dpw
cookie hash   : PfTMX6ZyBIjj104/jcuWQw==
log           : C:/Users/Dpw/AppData/Roaming/RabbitMQ/log/rabbit.log
sasl log      : C:/Users/Dpw/AppData/Roaming/RabbitMQ/log/rabbit-sasl.log
database dir  : c:/Users/Dpw/AppData/Roaming/RabbitMQ/db/rabbit-mnesia

starting database             ...done
starting core processes       ...done
starting recovery             ...done
starting persister            ...done
starting guid generator       ...done
starting builtin applications ...done
starting TCP listeners        ...done
starting SSL listeners        ...done

broker running

Does a similar procedure work for you?  If you are doing something
different, can you give us more information to help reproduce it?


 [][][] David Wragg       | mail: david.wragg at lshift.net
   [][] Senior Developer  | tel: +44 (0)20 7729 7060
 []  [] LShift Ltd        | web: www.lshift.net

More information about the rabbitmq-discuss mailing list