[rabbitmq-discuss] Rabbitmq server crash and no start more

Matthew Sackman matthew at lshift.net
Tue Jan 26 12:43:15 GMT 2010


On Tue, Jan 26, 2010 at 10:36:11AM -0200, Gustavo Aquino wrote:
> I did this question because I have tried it without success. No
> rabbitmq-server now rabbitctl recognize the RABBITMQ_NODENAME.
> I'm doing something wrong ?

Yes. Environment variables do not survive when you change user.

> My configurations:
> $ *export RABBITMQ_NODENAME=rabbit at Nefertiti*
> *rabbit at Nefertiti*
> $ ./start-rabbitmq.sh
> *node          : rabbit at 182-26-6-233*

This has not taken effect because start-rabbitmq.sh changes to the
rabbitmq user.

> udo rabbitmqctl list_queues
> Listing queues ...
> *Error: unable to connect to node 'rabbit at 182-26-6-233': nodedown*
> *diagnostics:*
> *- unable to connect to epmd on 182-26-6-233: nxdomain*
> - current node: 'rabbitmqctl46430 at 182-26-6-233'
> - current node home dir: /opt/local/var/lib/rabbitmq
> - current node cookie hash: diX16VkN3b6UrKJtDPVb1Q==

Not quite sure why this hasn't worked though...

matthew at mrnibble:~$ cat foo.sh
#! /bin/sh
echo $FOO
matthew at mrnibble:~$ export FOO=wibble
matthew at mrnibble:~$ echo $FOO
matthew at mrnibble:~$ ./foo.sh 
matthew at mrnibble:~$ sudo ./foo.sh

I.e. FOO does not appear when you become root. Put the NODENAME in the
/etc/rabbitmq/rabbitmq.conf file


More information about the rabbitmq-discuss mailing list