[rabbitmq-discuss] Running RabbitMQ with Erlware

david_sansot at playstation.sony.com david_sansot at playstation.sony.com
Mon Feb 8 21:48:03 GMT 2010

Thanks for your reply.

On 2/6/2010 12:11 PM, Matthias Radestock wrote:
> David,
> david_sansot at playstation.sony.com wrote:
>> We are in the process of updating our versions of rabbitmq and 
>> erlang.  To get the latest erlang on our box we decided to try 
>> erlware (We're running CentOS 5.4 and the latest we can get through 
>> ERPL is R12B).  Installing erl from erlware seemed to work fine 
>> (R13B03).  We installed rabbitmq 1.7.1 from the rpm.
>> When we try to start the server, we get an error that os_mon can not 
>> be started (yes, os_mon is installed):
>>     {"init terminating in
>> do_boot",{{nocatch,{error,{cannot_start_application,os_mon,{not_started,sasl}}}},[{init,start_it,1},{init,start_em,1}]}} 
> os_mon depends on sasl, and the above error indicates that sasl hasn't 
> been started.
> All the rabbit startup scripts we ship do start sasl automatically, so 
> it's strange that you see the above. What startup script are you 
> invoking?


> > We are able to start os_mon from the erl shell.
> Without starting sasl? If I try that I get the following:
> $ erl
> Erlang R13B03 (erts-5.7.4) [source] [smp:2:2] [rq:2] [async-threads:0] 
> [hipe] [kernel-poll:false]
> Eshell V5.7.4  (abort with ^G)
> 1> application:start(os_mon).
> {error,{not_started,sasl}}
> which is exactly the same error as above.
You caught me.  I was told this worked, but I didn't actually try it.  I 
just did try and got the same error you did.

> By contrast, when starting erlang with sasl enabled (in the same way 
> our startup scripts do) I get:
> $ erl -boot start_sasl
This looks to be the problem.  I don't have a start_sasl.boot file on 
the system.  I assume this should have come from erlware.  I need to 
look into this.  I can start sasl and then os_mon in the shell just fine.

Thanks Again,

More information about the rabbitmq-discuss mailing list