[rabbitmq-discuss] Return of 'getting started, broker runs; can't get status'

J Aaron Farr farra at apache.org
Tue Sep 22 15:09:15 BST 2009

You rock.  Details below.

On Tue 22 Sep 2009 19:36, Paul Jones <pauljones23 at gmail.com> wrote:

> We're starting to run low on ideas, but here are a few others that can be
> tried:
>    - Change the RABBITMQ_NODENAME in the rabbitmq-server script to
>    rabbit at localhost (or some other predictable host name), and then use the
>    -n flag on rabbitmqctl to force it as well.

replacing ${RABBITMQ_NODENAME} with rabbit at localhost and using
rabbitmqctl -n worked!

Previously it was using rabbit at gandalf, where gandalf was the computer
name.  Pinging gandalf.local still gives me, so I'm not sure
why this makes a difference, but apparently it does.

I can at least go from here.

If you want me to further debug this to figure out the root cause, I'm
happy to try anything else for you.

Thanks again!

   J. Aaron Farr

More information about the rabbitmq-discuss mailing list