[rabbitmq-discuss] rabbitmq 1.5.1-1 from debian pool fails to start

christopher hoover ch at murgatroid.com
Fri Jan 30 03:10:57 GMT 2009

> Matthias Radestock wrote:
> > christopher hoover wrote:
> >> Note: I've seen it in two places so far (Debian testing, Ubuntu
> >> Jaunty), so
> >> I suspect it is not that hard to reproduce.
> >>
> >> The other clue that I suspect is important is that 1.5.0 works.
> >
> > These are all good data points. Alas I have been unable to reproduce
> the
> > problem. Hence giving me access to a machine that exhibits the
> behaviour
> > you are seeing is the next logical step.
> Have you had any success yet getting RabbitMQ to work? 


I tried running the /etc/init.d/rabbitmq steps by hand.  Almost by accident,
I discovered that rabbitmq would start properly with rabbitmq's home
(/var/lib/rabbitmq) as cwd, but would fail with / or even /tmp as cwd.

Editing /etc/init.d/rabbitmq to tweak the chdir to /var/lib/rabbitmq makes
it work fine.

I'm still not sure of the root cause.  I looked at the diffs in hg between
the two releases, but I couldn't come up with an explanation.   But my
Erlang is pretty poor, so I may have missed something.


More information about the rabbitmq-discuss mailing list