[rabbitmq-discuss] Erlang client handshake problem

Dave Bryson daveb at miceda.org
Wed Jan 28 00:13:04 GMT 2009


Thanks for the response.  I've been racking my brain trying to figure  
out what's going on:

As for versions of the client, I've tried:
-  latest snapshot erlang-client in the zip from the download link off  
the rabbitmq website
-  and also tried the latest version from repo here: hg clone http://hg.rabbitmq.com/rabbitmq-erlang-client/

For servers, I tried:
  - the generic unix version of rabbitmq 1.5.1 from the tar on the  
  - and also built it separately from the repository.

In all cases I continue to have the same problem:  the client doesn't  
connect.  When I run "make test_network"  the basic_get_test() shows a  
*time out* and the client just sits there... the same happens if I try  
and use the api directly from the console via:

erl -pa ebin rabbitmq_server/ebin -boot start_sasl

 > C = amqp_connection:start("guest", "guest", "localhost").

If I look in the rabbit server logs I see:

=INFO REPORT==== 27-Jan-2009::10:31:48 ===
accepted TCP connection on from

=INFO REPORT==== 27-Jan-2009::10:31:48 ===
starting TCP connection <0.167.0> from

=ERROR REPORT==== 27-Jan-2009::10:31:58 ===
error on TCP connection <0.167.0> from

That's it, no erl dumps or any other error shows up on the client.

I tried a separate test against the server using a AMQP Ruby client  
against the server and all worked without a problem.

My Environment:

- Mac OS X 10.5.6
- Erlang 12b-5

Any help is greatly appreciated!

On Jan 27, 2009, at 4:35 PM, Ben Hood wrote:

> Dave,
> On Tue, Jan 27, 2009 at 2:02 PM, Dave Bryson <daveb at miceda.org> wrote:
>> I have not been able to get the Erlang client to connect to the
>> server. I've tried connecting to both the local server and the
>> rabbitmq public server and getting the same problem on
>> both...basically the client just hangs trying to make the connection.
>> This happens when I run the network_test as well.   Looking in my
>> local server log I keep seeing the same errors over and over:
> Can we have a few more clues about your setup, e.g. which specific
> version of the client you are running and how you are running it?
> Ben

More information about the rabbitmq-discuss mailing list