[rabbitmq-discuss] RabbitMQ starting problem on R12B-5

Matthias Radestock matthias at lshift.net
Thu Nov 20 09:06:24 GMT 2008


ferrety ferrety wrote:

> 1> erlang:system_info(version).
> "5.6.4"

So far so good, but ...

> 2> code:which(mnesia).
> "/usr/lib/erlang/lib/mnesia-4.4.7/ebin/mnesia.beam"

That is R12B-5's version of mnesia.

>> Are you saying that R12B-4 + 1.4.0 actually worked for you at some point?
> Yes, this is exactly what happen to us. The first time we installed
> Rabbit, it just worked without any problem.
> When moving to R12B-5, problems started and it' wasn't possible to
> return to R12B-4 and get it run anymore.

I suspect that when you downgraded to R12B-4 you simply installed it 
over R12B-5, which may have left the R12B-5 libraries in place alongside 
the R12B-4 libraries. You will probably find that you have several 
mnesia-* dirs under usr/lib/erlang/lib. If so, please remove all of 
/usr/lib/erlang and re-install R12B-4 after that.


More information about the rabbitmq-discuss mailing list