[rabbitmq-discuss] RabbitMQ starting problem on R12B-5

Matthias Radestock matthias at lshift.net
Wed Nov 19 23:47:44 GMT 2008


ferrety ferrety wrote:
> On R12B-4, here's the problem:
> $ /etc/init.d/rabbitd start
> [...]
> {"init terminating in
> do_boot",{{nocatch,{error,{cannot_start_application,rabbit,{{bad_type,realm_exchange,{realm_resource,'_',<<12
> bytes>>}},{rabbit,start,[normal,[]]}}}}},[{init,start_it,1},{init,start_em,1}]}}

Are you *sure* that is R12B-4?

Please run
in an Erlang shell and send me the results.

>> My colleagues have been using that combination without any problems.
> We did it too.

Are you saying that R12B-4 + 1.4.0 actually worked for you at some point?

>> I recommend performing an installation of Erlang R12B-4 and rabbitmq-1.4.0
>> on a "clean" system
> We did that 2 times today Mathias. Same result on 2 diffrent machines
> No other application is running on these two boxes except our Erlang
> app's and the expected RabbitMQ.

And these were clean machines, with *no previous Erlang or RabbitMQ 


More information about the rabbitmq-discuss mailing list