[rabbitmq-discuss] Naming RabbitMQ nodes with complete domain names

Santiago Ezcurra sezcurra at gmail.com
Fri May 24 00:37:17 BST 2013

Hi there.....I know this is old thread, but I'm having the same 
problem.....the thing is that I'm trying to build a cluster on amazon ec2. 
there, there is no domain and the machines only have a hostname of the form 
ip-0-0-0-0. everything works fine for one node (and erlang starts with 
-name rabbit at ip-x-x-x-x), but when i try to join cluster to another node, 
there is no name resolution happening between both machines (other than 
specifying mutually on respectives ec/hosts). 
those machines does recognize the name *ip-x-x-x-x.ec2.internal*....but I'm 
just failing to configure this name. When i tried specifying this long name 
in NODENAME in env file, it's when erlang (or rabbitmq, don't know) 
complains with "can't get short name whatever". and maybe it's because the 
newer version, but I can't find where to change the -sname by -name in any 
scripts.....could you please have any advice for me ??

Thanks !


On Saturday, February 19, 2011 7:52:21 PM UTC-3, Matthias Radestock wrote:
> Max,
> Max Bridgewater wrote:
> > Thanks Alvaro. Unfortunately this still doesn't work for me. The steps
> > I followed are:
> > 
> > a) Stop rabbitmq
> > b) Change the option -sname to -name in rabbitmq-multi
> You'd also need to change this in rabbitmq-server.
> However, ...
> >>>>> The original issue is this: I'm trying to use JInterface to connect 
> to
> >>>>> a rabbitmq cluster hosted on EC2. But I keep getting "Cannot connect
> >>>>> to peer node". My understanding is that this error is happening
> >>>>> because I'm using the address 'rab... at domain.org <javascript:>' to 
> contact the
> >>>>> remote RabbitMQ node named: rabbit at domain. (Note the missing TLD).
> >>>>> That is, because there is no exact  match between the node name given
> >>>>> to JInterface and the name of the node it is connecting to, the
> >>>>> connection fails.
> >>>>>
> >>>>> I desperately tried configuring RabbitMQ to take the complete domain
> >>>>> name (domain.org) instead of just the short domain name (domain). 
> Any
> >>>>> suggestion on how to resolve this issue?
> I'd suggest configuring your local name resolution s.t. the hostname of 
> the machine rabbit is running on resolves to the correct IP. That way 
> you don't have to mess with long names.
> Btw, what are you trying to accomplish with JInterface?
> Regards,
> Matthias.
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq... at lists.rabbitmq.com <javascript:>
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130523/1f3748d4/attachment.htm>

More information about the rabbitmq-discuss mailing list