[rabbitmq-discuss] Problems with umbrella make files

Steve Powell steve at rabbitmq.com
Wed Apr 18 16:55:50 BST 2012

Hi Alvaro,

I can reproduce this behaviour. It seems like making the rabbitmq-server
includes making the plugins, which somehow tries to re-make the server
-- and I (eventually) recurse off the forking stack.

Making the release beforehand probably stops the recursion starting.

This probably started when we decided to ship all the plugins with the
server -- so we build them as part of the rabbitmq-server build now. But
I'm slightly surprised that no-one has complained about this already.

In development we build rabbitmq-server from our development umbrella
repo, which INCLUDES the public-umbrella repo, so the plugins are built
after the server is already done (I think). So we don't see this,

I'm going to see if I can find out where the recursion happens and see
why it does.

Steve Powell  (a happy bunny)
----------yet more definitions from the SPD----------
chinchilla (n.) Cooling device for the lower jaw.
socialcast (n.) Someone to whom everyone is speaking but nobody likes.
literacy (n.) A textually transmitted disease usually contracted in childhood.
ebola (n.) A Yorkshire cricketer.

On 15 Apr 2012, at 20:48, Alvaro Videla wrote:

> Hi,
> I'm trying to run the "make plugins" target from rabbitmq-server Makefile (obtained from the umbrella repo)
> If I run the target like this it fails:
> make plugins PLUGINS_SRC_DIR="`pwd`/.." VERSION=2.8.1u
> Since I start to get the same output again and again. See this gist: https://gist.github.com/2394475
> Unless I ran before the following target from the rabbitmq-public-umbrella Makefile:
> make release VERSION=2.8.1u
> I understand that the "plugins" target will call that one, so I'm puzzled here.
> I also tried adding the following target in the rabbitmq-server/Makefile
> mydebug:                                                                                                                                                                                                    
>         $(MAKE) -C "$(PLUGINS_SRC_DIR)" clean
> Running it like: 
> make mydebug PLUGINS_SRC_DIR=..
> also fails with the same output as in the previous gist.
> Any ideas on what might be wrong? Am I missing something?
> Regards,
> Alvaro
> -- 
> Alvaro Videla
> Sent with Sparrow
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-discuss at lists.rabbitmq.com
> https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list