[rabbitmq-discuss] Cannot get 3 Node cluster to work

steve flitcroft steve.flitcroft at gmail.com
Wed Nov 30 10:35:40 GMT 2011

Hi Emile,
Thanks for getting back to me. I have sorted the issue this morning. I
reset all the clusters and reinstalled RMQ and followed that guide - I
was using an earlier blog post previously.Everything is good now. I
now have a HaProxy balanced three node cluster sorted.
On Nov 30, 10:22 am, Emile Joubert <em... at rabbitmq.com> wrote:
> Hi Steve,
> On 29/11/11 16:25, steve flitcroft wrote:
> > Hi All,
> > I am having issues getting a 3 node cluster to work. I am able to
> > cluster any combination of the 3 nodes with each other however when i
> > try to join the third node into the cluster it keeps telling me that
> > "Mnesia could not connect to some nodes".
> If any two nodes can connect then all three should cluster without
> difficulty. Have you tried following the clustering transcript exactly
> and found the same error?
> (http://www.rabbitmq.com/clustering.html#transcript)
> What log entries appear at the time time of the error message?
> Are the ports reported by "epmd.exe -names" reachable from the other
> nodes in all cases, in addition to port 4369?
> Does the use of the force_cluster command help?
> -Emile
> _______________________________________________
> rabbitmq-discuss mailing list
> rabbitmq-disc... at lists.rabbitmq.comhttps://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

More information about the rabbitmq-discuss mailing list